DocuShare User's Guide
11. Using the Windows Client
Overview

Mounting a DocuShare Server on Windows Explorer
Accessing a Mounted DocuShare Server via Windows Explorer

Viewing and Editing DocuShare Files on the Windows Client

New Function Buttons in the Windows Client

New Menus in the Windows Client

Working with DocuShare Files in the Windows Client

Searching DocuShare within the Windows Client

Configuring Options

View the Work-In-Progress Folder

Open/Save/Save As... Dialogs

Table of Contents     Searching in DocuShare     DocuShare ODMA Client

Overview

The Windows Client allows you to work with a DocuShare repository of files (or several) from within Windows Explorer. Once you mount the server and log in, DocuShare will appear as a separate drive in the familiar Windows Explorer tree environment. When you click on the DocuShare drive from Windows Explorer, DocuShare collections appear as folders, and files appear as the appropriate icons. You can bypass normal upload procedures and copy files to a DocuShare collection from your local or network drives, or you can pull drag and drop files from DocuShare directly to your computer, avoiding the download step. Simply select the file (or files) you want and drag it to the folder to which you wish to upload or download. It works the same as when you drag files around within your computer or to and from network drives.


Mounting a DocuShare Server on Windows Explorer

The DocuShare Windows Client must be installed on your computer before you can mount a DocuShare server on Windows Explorer. See Installing the Windows Client, Chapter 1. Once you have installed the Windows Client, click the DocuShare icon as it appears in Windows Explorer.

All DocuShare servers that have been mapped to the Windows Client will be displayed.  Initially, no servers are mapped.

To map a DocuShare server:

  1. Either select the Add Server icon or choose Map DocuShare Server from the Explorer Tools Menu.  The Step 1 dialog box of the Map Server Wizard will appear.

  2. Under Home URL, type in the name of your DocuShare server (e.g., http://sales.acme.com).  If you prefer, you can use the Browse... button to launch a web browser for you to select the DocuShare server with.  The DocuShare Windows Client supports connections to servers via standard HTTP or SSL so either http:// or https:// should be used as the URL prefix.

  3. If a proxy server is needed, press the Advanced button. If the DocuShare server you are using is local, do not use a proxy server.

  4. Press Next. The Step 2 dialog box appears. If you do not have an account on the DocuShare server entered in Step 1, press the Registry button. This will take you to the Web page to create an account.

  5. Enter your username under Account Name.

  6. Enter your password under Password. (If mapping as a Guest, leave the Password field empty.)

  7. If you do not have an account on the DocuShare server, check the "Create a new account" checkbox and enter the confirmation password, email address, and user name. A new account will be created for you on the server with this user ID and password.

  8. Press Next. The Step 3 dialog box appears.

  9. Enter the name you want to appear in the Windows Client under Folder Name in Explorer. Although this name can be different than the name of your DocuShare website, you probably want to give it the same name or a related, meaningful name to avoid any confusion with other servers.

  10. Enter a name under Work-in-progress directory name that is at least four characters long.

  11. Press Next. The Step 4 dialog box lets you review the information you entered in steps 1 through 3. If the information is correct, press Finish to create the server folder. If you experience a login problem, see Chapter 14, Troubleshooting.

At this point, the new folder for the server will appear in Windows Explorer under the DocuShare icon.

In addition to mapping servers, specific collections within servers can be mapped into the DocuShare Windows Client root directory. A mapped collection allows the collection to be accessed directly without having to walk down the server's tree hierarchy. These mapped collections must exist on a mapped server.

To map a DocuShare collection:

  1. Make sure the server that the collection resides on is already mapped.

  2. Select the Add Collection icon. The Map Collection dialog is displayed.

  3. Select the server on which the collection resides.

  4. Walk through the collection hierarchy and select the collection. Click OK.

  5. The new folder for the mapped Collection will now appear under the DocuShare icon.

To remove a DocuShare server from the DocuShare Windows Client:

  1. Select Disconnect DocuShare Server from the Windows Explorer Tools Menu.

  2. Select the DocuShare server you wish to disconnect.

  3. Press OK.

The server you selected for removal should no longer appear on the Windows Explorer interface. If the server does still appear, select Refresh in the Windows Explorer View menu.


Accessing a Mounted DocuShare server via Windows Explorer

To access a mounted DocuShare server via Windows Explorer:

  1. Double click on the DocuShare icon that appears in your Windows Explorer tree structure. See example below:

  2. Type your password in the dialog box, which may appear, then click OK. Remember that your password is case-sensitive. If you make a mistake and see an error message, try entering your password again or see your Site Administrator.

  3. The DocuShare server then opens onto your Windows Explorer Interface, and you will see the familiar folder pattern of collections and objects that make up the DocuShare site.

At this point, you can point and click to open DocuShare collections on your DocuShare site as if they were folders on one of your local or network drives.


Viewing and Editing Files with the DocuShare Windows Client

Viewing and editing DocuShare files on the Windows Client is similar to viewing and editing files on one of your local drives in Windows Explorer. Collections appear as Windows Explorer folders that may contain files, URLs, calendars, bulletin boards or other collections/folders. Files will appear with their corresponding icons (e.g., for Microsoft Word files).

To open a DocuShare collection/folder in the Windows Client, simply double click the folder with your mouse. The contents of that collection/folder will then appear in the right-hand side of the Windows Explorer Interface. Remember that permissions still apply, so depending on your access, you may not be able to view restricted collections or folders. See Chapter 3, DocuShare Permissions for further information.

To open a DocuShare file, simply double click on the file name. There are two ways to "open" a DocuShare file. The default response to double clicking on the file is to open the corresponding application with the file set to read only. This is called browse mode. Alternatively, you may open the file for editing and save it back to DocuShare when you are done. This is called check out. When you check out a file, the original copy on the DocuShare server is locked while you edit the file so that others will not be able to create new versions while you are editing the current version. Both options are available from the menu that appears when you click your right mouse button on the file name. You can configure your default action in response to a double-click from the DocuShare settings screen.

The DocuShare Windows Client supports the following applications for check out:

Other applications may or may not correctly check out of DocuShare or save back to DocuShare. See Chapter 14, Troubleshooting DocuShare.

You may also independently lock or unlock a file. When a file is checked out, it is automatically locked. You may not unlock a checked out file. A locked file can only be browsed, and cannot be checked out.

Saving the file in the corresponding editor will save the file locally. When you exit the corresponding editor, the DocuShare Windows Client will automatically upload the saved local file to the DocuShare server and unlock the file.


New Function Buttons in the Windows Client

Most of the function buttons on the Windows Client are the same as the function buttons in Windows Explorer, but there are a few differences. The table below gives a description of the function buttons in the Windows Client.

Up one Level: Takes you one level higher in the tree structure. It works the same for DocuShare as it does for Windows Explorer.

Large Icons: Displays large icons. It works the same for DocuShare as it does for Windows Explorer.

Small Icons: Displays small icons. It works the same for DocuShare as it does for Windows Explorer.

List: Displays icons in a list. It works the same for DocuShare as it does for Windows Explorer.

Details: Displays icons in a list with details about the files. It works the same for DocuShare as it does for Windows Explorer.

Thumbnail: Displays large icons of document files and thumbnail images of graphics files.
Note: Thumbnails are only available when connected to a DocuShare server running version 2.1 or higher.

Edit: Opens an edit program for the file. The specific response depends upon the edit program. For supported applications, DocuShare will open the application for editing and offer to save the editing file back to the same DocuShare location when you close the window. For unsupported applications, DocuShare will open the file in read-only mode. See the Editor Support section for more details. It works the same for DocuShare as it does for Windows Explorer, but you will be offered the ODMA option (see ODMA Client).

Print: Prints the current file. It works the same for DocuShare as it does for Windows Explorer.

Add Document: Adds a document to the current collection/folder. This function button is unique to the DocuShare Windows Client.

Create New Version: Creates a new version of the file with which you are working. This function button is unique to the DocuShare Windows Client.

Create New Collection: Creates a new collection within the open collection. This function button is unique to the DocuShare Windows Client.

Delete: Deletes the selected file. It works the same for DocuShare as it does for Windows Explorer, except that you must have Manager access to delete a file.

View Version History: Shows you the version history of the current document. This function button is unique to the DocuShare Windows Client.

View Properties: Displays the properties of the selected file. It works essentially the same for DocuShare as it does for Windows Explorer.

Undo: Undoes the last action. This Windows Explorer function is not supported in the DocuShare Windows Client.

Map Server. Brings up the sequence of screens to map to another DocuShare server. This button only appears when the Xerox DocuShare drive is selected.

Disconnect Server. Allows you to remove one of the currently mapped DocuShare servers. This button only appears when the Xerox DocuShare drive is selected.



New Menus in the Windows Client

In addition to the Windows Explorer function buttons, you will notice various pop-up menus when you right-click your mouse within the Windows Client. As with the function buttons, these menus closely resemble the standard Windows Explorer right-click menus with a few differences.

Whenever DocuShare content is selected, the Windows Explorer Tools menu contains an additional section for three DocuShare-specific commands. Map DocuShare Server… allows you to connect to additional DocuShare sites. Disconnect DocuShare Server… allows you to remove currently mapped DocuShare sites. This is also useful if you want to login as a different user. Go to DocuShare URL… brings up a window in which you can enter a DocuShare location directly. The window offers a partial URL as a hint that you must complete.

On Windows 2000, the Find Files in DocuShare... item is also available under this Tools menu.

This menu appears if you right-click your mouse in the All Folders section (i.e., left side) of the Windows Client. Functions are an abbreviated list of those found in Windows Explorer.

Open in Web Browser launches an Internet Explorer window to the selected server.

New allows you to create a new folder (i.e., collection) or a new document. You can also create new Calendar, Bulletin Board, and URL objects.

Edit allows you to copy the DocuShare URL or DocuShare Properties URL for the folder onto the clipboard, along with the standard edit operations of Cut, Copy, Paste, and Delete.

This menu appears if you right-click your mouse in the Folder Contents section (i.e., right side) of the Windows Client. Functions are mostly the same as in Windows Explorer. The DocuShare functions are listed below.

Open in Web Browser launches an Internet Explorer window to the selected collection.

New allows you to create a new folder (i.e., collection) or a new document. You can also create new Calendar, Bulletin Board, and URL objects.

Edit allows you to copy the DocuShare URL or DocuShare Properties URL for the folder onto the clipboard, along with the standard edit operations of Cut, Copy, Paste, and Delete.

View lets you choose among the following: large icons, small icons, list, details, or thumbnail image view.

 

This menu appears if you right-click your mouse on a file in the Folder Contents section (i.e., right side) of the Windows Client. Functions are a mix of Windows Explorer and DocuShare. The DocuShare functions are listed below.

Browse opens the selected file.

Check Out opens the selected file and locks it so others cannot use or change this file while you have it active.

Print opens the selected file and issues a Print request to the editor.

Open in Web Browser launches an Internet Explorer window to view the selected item.

Lock locks the file.

Unlock unlocks the file.

Version History lets you view the version history of the file.

New creates a new version of the file using the existing file.

Edit allows you to copy the DocuShare URL or DocuShare Properties URL for the object onto the clipboard, along with the standard edit operations of Cut, Copy, Paste, and Delete.

View lets you choose among the following: large icons, small icons, list, details, or thumbnail image view.

Rename lets you rename the file. This will change the file's Title property on the DocuShare server.

Properties displays a window for viewing and editing the object's properties.



Working with DocuShare Files in the Windows Client

Working with DocuShare files on the Windows Client is much the same as working with regular files from your local or network drives on Windows Explorer. Using standard Windows Explorer drag and drop operations, you can copy files to a DocuShare collection from your local or network drives, or you can copy files from DocuShare directly to your computer.You can also copy and move DocuShare files from folder to folder within the DocuShare using drag and drop operations. Other standard Windows Explorer features are available as well, such as Rename, Delete, and Properties.

Adding, Copying, and Deleting Files or Folders

To add (i.e., upload) files from a local or network drive to a DocuShare folder (i.e., collection) on the Windows Client, follow the steps below.

To add files or folders:

  1. Select the file(s) you wish to add with your mouse and drag it to the desired DocuShare folder.
    Note: Remember that you must be logged in and have Writer permission to add files to a DocuShare collection.

  2. A confirmation message box will appear. Click Yes.
The file will now appear in the DocuShare folder you designated. If you do not see the copied file, right click your mouse in the contents area (i.e., right side of Explorer Screen) and select Refresh.
Note:You can also add files to DocuShare via the ODMA Client. See Chapter 12: The DocuShare ODMA Client for further information.

The above process works the same for adding folders from a local or network drive to a DocuShare folder on the Windows Client. All contents of the added folder will be included.

To copy files from a DocuShare folder to a folder on your local or network drives:

  1. Select the file(s) you wish to copy with your mouse and drag it to the desired local or network folder.
    Note: The Confirm Item Copy screen does not pop up for this type of action (i.e., a download).

  2. Use the same select and drag procedure as above to copy files from one DocuShare folder (i.e., collection) to another.

The Confirm Item Copy screen will pop up if you copy files from one DocuShare server to another, but otherwise the process is the same. Remember that you must have Write permission to add files to a DocuShare collection even if the files are coming from another DocuShare collection or server.

The above process works the same for copying folders from a DocuShare folder on the Windows Client to a local or network drive. All contents of the added folder will be included.

Note: Dragging files from DocuShare to the Windows Recycle Bin will not delete the file from DocuShare. Files should only be dragged from DocuShare and dropped into regular file locations.

To delete files from DocuShare on the Windows Client:

  1. Select the file(s) with your mouse and press the delete function button on the Windows Client Interface or the delete button on your keyboard.
    Note: Remember, you must have Manager access to delete files or folders from DocuShare.

  2. A confirmation screen will appear. Click Yes if you are certain you want to delete the file or folder.


The file or folder is now deleted. You may need to select Refresh from the right mouse click menu to reload the page and see the deletion.

Versioning and Locking Files

Versioning and Locking Files basically works the same way as it does in the web version; see Chapter 5, DocuShare Files for in-depth information. Follow the process below to create a new version of a file on the DocuShare Windows Client.

To create a new version of a file:

  1. Click on the Create New Version function button at the top of the interface or choose New à Version from the mouse right-click menu. The file must be selected for you to use the right-click menu.
    You can also drag and drop a local file onto a file in DocuShare to create a new version.
    Note: You can not drop a DocuShare file onto another DocuShare file to create a new version.

  2. The Create New Document Version dialog box appears:



  3. Enter the file name or select it by using the Browse key.


To view the Version History of a document on the DocuShare Windows Client, select the file by right-clicking it and choose Version History from the menu. You can also view the version history by clicking the View Version History function button at the top of the Windows Client interface. Within the Version History Dialog, you can right-click a version and choose version-specific actions from the menu such as Browse, Copy, and Copy URL.

To lock a file on the DocuShare Windows Client, select the file by right-clicking it and choose Lock from the menu that appears. A padlock icon will appear to the right of the document icon.

You can also Checkout a document by selecting the document with a right mouse click and choosing Checkout from the menu. This automatically opens the file and locks it so you can work on it. See Chapter 12, The DocuShare ODMA Client for further information.

To unlock a file on the DocuShare Windows Client, select the file by right-clicking it and choose Unlock from the menu that appears. The padlock icon will disappear.

Editing File Properties

You can view and edit the properties of a file with the Properties Dialog.

To display the Properties Dialog,:
  1. Click on the Properties function button at the top of the interface or choose Properties from the mouse right-click menu.


  2. The Properties dialog box appears:



  3. Inspect other tabs as required.



Searching DocuShare with the Windows Client

To search DocuShare with the DocuShare Windows Client:

  1. Select Find ® Files on DocuShare from the Explorer Tools Menu.



    On Windows 2000, the Find Files in DocuShare item is available directly under the Tools menu. DocuShare Find is not integrated with the Windows 2000 Search interface in DocuShare 2.2.

  2. The DocuShare Find File dialog box appears.



  3. Fill in your search criteria as necessary. The search can be issued across multiple servers, or restricted to just a certain collection on a server.

  4. There are 4 tabs of criteria at your disposal: Title & Location, Date Modified, Advanced Search, and Options. These 4 tabs together mirror the search criteria options from the Web view.

  5. Click Find Now when you are ready to start the search.

  6. The Search Results appear underneath the Find File box.



  7. To copy found files to your PC, you can use the regular drag and drop method. To check the properties of an item, right-click on an item and select Properties from the menu.

    If you edit the properties of an item in the search results, you'll note that an exclamation icon is displayed in the search results next to the item to denote it has been modified.

To exit the search dialog box, click on the X in the upper-right-hand corner.


Configuring Options

There are several options on the DocuShare Windows Client that you can configure. To access the options, double-click the DocuShare Client Properties icon in the Windows Control Panel. Alternatively, you can right-clickon the red Xerox icon in the toolbar of your Windows Explorer interface (On most machines, the will be located at the bottom right corner – the Start button is usually in the bottom left corner.) When you right click on the icon, a short menu appears:

Choose Settings...

Note: Disable ODMA from this menu will turn off the ODMA option, and View WIP Folder shows you information about the Work in Progress (if there is one). About DsClient gives you license and version information on the DocuShare Windows Client.

After you select Settings, the DocuShare Client Properties dialog box appears.

Note: The options shown as selected in the following examples are the DocuShare Windows Client default options. Your Site Administrator can help you figure out the best settings for your machine and requirements. The DocuShare Properties dialog offers various options regarding the DocuShare Windows Client's behavior.

ODMA Settings

Windows Explorer

Windows Common "Open/Save As" Dialogs

General
The "Enable network event logs" field allows you to tell the DocuShare Windows Client to log all error events. For any network errors, the Windows Client displays an exception report dialog and shows the logged information under the "Event Log" tab.

FileTypes Tab
The File Types tab allows the Windows Client use of editor applications to be modified. Because many different editors behave in different ways, the DocuShare Windows Client allows fine-tuning of this editor connection.

Note that changes to these settings do not affect how the Windows Client opens files for browsing. The Windows Client delegates the task of launching an associated editor application for file browsing to Windows itself. Therefore, to modify the browser behavior, the Windows file type settings must be modified through the Windows Explorer. Refer to a Windows user guide for more details on editing file type associations in Windows.



You cannot edit the file type. The Windows file type (extension) is set when you first check in a file. The file extension name is the last part of the filename you specified. The MIME type is automatically assigned by DocuShare when the file is indexed. You can edit the MIME type using the DocuShare Client. To do this, open the Properties dialog for the file and either enter a new MIME type specifier, or select from the drop-down list.

If the file you check out does not contain a file extension, the DocuShare Windows Client uses the MIME type setting to generate one. The Windows Client always uses the file extension to determine which editor application to use.

Depending on the editor application, the Windows Client needs to use a different checkout method. The selected method is shown under "Checked out using". The program file or command line that is used to run the editor program is shown below the selected method. The DocuShare Windows Client uses the following checkout methods (also mentioned as editor launch methods elsewhere in this document):

  • ODMA protocol
  • Custom handler
  • OLE protocol
  • DDE protocol
  • Process monitoring
  • None (file is uneditable)

  • These methods are listed according to the level of editor integration. You should select the method for the highest level of which your editor application is capable. If the selected method does not work for your editor program, change it to a lower method. If the file type does not designate an editable document or media data file, you should select the None method to disallow checkout.

    Make sure that the file extension and MIME type settings are correct. Since the Windows Client first looks at the file extension, if the file extension is not correct, the Windows Client may not run the correct editor program even if a correct MIME type is given. To work around this problem, download the file, give it the correct file extension name, and upload it as a new version of the same file (using the New Version menu item or the drag and drop method). These supported editor launch methods are described in more detail below.

    The ODMA protocol allows the editor to gain direct control over the DocuShare file access. A file opened using this protocol may be safely saved as a new document (using the File | Save As menu item). The Windows Client can use the ODMA protocol if the file type is one of the following:

  • MS Word 97 and 2000 document (extension .doc)
  • MS PowerPoint 97 and 2000 document (extension .ppt)
  • MS Office Binder 97 and 2000 document (extension .bnd)
  • Corel WordPerfect versions 8 and 2000 (extension .wpd)
  • Lotus Wordpro versions 8 and 2000 (extension .lwp)

  • An editor application may support ODMA in general, but if it does not support the ODMA command line syntax, the ODMA protocol will not be used to check out a file directly from Windows Explorer. Visio is one such editor application. In the case of Visio, the Windows Client pre-selects the OLE protocol.
    A "custom handler" is a special Windows Client program that was written specifically for handling the tasks of opening a file of a particular file type and tracking its life cycle in a particular editor application. The following are supplied by the Windows Client:

  • MS Excel 97 and 2000 worksheet (extension .xls)
  • Corel WordPerfect versions 7, 8 and 2000 (extension .wpd)
  • Corel Presentations versions 8 and 2000 (extension .shw)
  • Lotus Freelance versions 7 and 2000

  • Many popular editor programs support OLE (Object Linking and Embedding) to open and track a file. For those editors, the protocol allows the editor to link with the Windows Client using the OLE file linking protocol. When the OLE protocol is in use, the Windows Client does not need to periodically query the editing state of the file. The OLE protocol is preferable to the DDE and process monitoring methods. The latter methods require the Windows Client to perform periodic state polling in the background in order to track the lifecycle of the checked out file. In NT4 and Windows 2000, Windows can provide non-OLE applications with OLE packager support. The packager enables a non-OLE application to act as if it supports the OLE file linking protocol and allows notification linkage to be established between the Windows Client and the opened file (via the packager's OLE handler).

    The DDE protocol may be selected if the editor application supports the standard DDE system topic for opening a file. DDE permits an inquiry to be performed by the Windows Client about the current editing state of the file. The Windows Client makes this inquiry periodically and uses the queried information to update the file-tracking status.

    If the editor application does not support any of the above methods, the Windows Client can use the Process Monitoring method to track the editor. When this method is selected, the Windows Client periodically checks the process state of the editor. However, because this method does not allow the Windows Client to track the file state itself (e.g., closure of the file window in the editor window), the Windows Client defers check-in until the entire editor application closes. This means that if the editor holds multiple file windows and you close one of the file windows, that closed file does not trigger immediate check-in. Only when you close the whole application does the Windows Client run the check-in dialog. Therefore, when this method is selected, you must exit the editor application in order to initiate a DocuShare check-in.

    When you select the ODMA, custom handler, or process monitor method, you will be asked if you want to open the file using an editor program that is different from the currently assigned editor. Select 'Yes' to map the file type to a different editor. A list of remappable file types will be presented. Select a desirable file type. The next time you check out a file of that file type, the Windows Client will use the remapped file type to find an editor program. Note that the Windows Client uses this file type remapping mechanism to re-assign some common file types to non-default editors (e.g., editors selected by Windows). For example, the Windows Client uses WordPad to open text (.txt) files although the default text editor is Notepad.

    Folders Tab


  • The "Save Local folder" field sets the default folder on your PC used for storing a local DocuShare file. For example, if a checked out file fails due to a network problem while it is being uploaded to DocuShare, the Windows Client allows you select an emergency folder to save the file locally. The folder you enter in this field will be the default for this emergency save. Use the ... button to select a different folder. If you directly edit the folder's path specification, make sure that the path is correct in syntax and that the folder exists.

  • The "Automatically clean" option tells the Windows Client to delete temporary work files it created in the cache and work folders when the current Windows session terminates. Check this option to delete temporary files.

    Note that the checkbox is gray. The checked state means that the all work folders including the ODMA subfolder will be cleaned. The gray state means that all work folders except the ODMA subfolders will be cleaned. The unchecked state means that work folders are not cleaned when Windows terminates. If there are any transient or orphaned files left, they will not be deleted automatically. To manually clean work folders, use the Clean button.

  • The icon list under "Work folders" shows the base work folders of the DocuShare Windows Client. To see subfolders, double-click on the icon or name of a folder. The folder expands to a tree of nested subfolders. A brief description and status of the selected folder is shown under "Description" and "Status" fields.

  • To see the contents of a folder, select the Open button. The contents will be displayed using a Windows folder window. You should not manipulate (e.g., rename or delete) any of the files in the folder window unless you are certain that the file is not being managed by the DocuShare Windows Client. To verify if the file is being managed by the DocuShare Windows Client, open the DocuShare File Monitor window. If the file is listed there, do not do anything. Sometimes the File Monitor loses record of a checked-out file (e.g., due to an abnormal termination of the editor) and the working copy of the file becomes orphaned. In such a case, you may move or delete the file.

  • The Move button lets you move the selected folder to a different location. The current location is described under the "Status" field. You can move the base work folder and cache folder; however, you are not allowed to move the data folder.

  • The Delete button allows you to delete the selected work folder. All contents of the folder will also be deleted.

  • The Clean button lets you clean up a work folder. Only work files that have been logged by the Windows Client will be deleted.

    Note: These folders can only be moved or deleted if the Windows Client has not been used during the Windows Session. If you want to move or delete one of the folders but the buttons are disabled in the Settings dialog, reboot Windows and access the Settings dialog directly through the Windows Control Panel.


    View the Work-In-Progress Folder





    The DocuShare Client Work-In-Progress (WIP) Folder tracks all activity in the Windows Client. The DocuShare File Monitor (displayed above) allows you to manage the contents of the WIP folder. Each file that is being edited, locked, or cached in the DocuShare Client temp directory is listed. These files can be copied directly to the local file system, unlocked, or deleted from the WIP Folder.

    For diagnostics, the DocuShare Client activity log is accessible through the WIP window. A hidden pane at the bottom of the WIP window (signaled by the cursor changing above it) can be pulled up to reveal the activity log.

    Columns of the WIP list

  • Title - Shows the document title and file type icon of the file. If the file is locked, a padlock is placed next to the title.

  • Editor window - Shows the name of the editor's executable module, the name of the editor class, or the editor's window title.

  • Modified - Yes indicates that the work-in-progress copy of the file has been modified, and No indicates that the local copy has not been modified since the checkout time or since the last check-in.

  • Last check-in - Shows the time of the last check-in. If no check-in has been performed, this column shows "N/A."

  • File handle - Indicates the number of DocuShare file handles assigned to the file being edited. If no handle number is shown, the local file has not been checked in yet, or the file is orphaned. A file may become orphaned if the DocuShare File Monitor window was closed inadvertently while you were still editing (that is, a system error happened which caused Windows to shut down).

  • Collection - Indicates a DocuShare collection to which the checked-out file belongs.

  • Server address - Shows the home URL of the DocuShare server.

  • File location - Shows the full path name of the file being edited.

  • Activity Log
    The activity log maintains a chronological listing of events that occur with regard to the DocuShare File Monitor. This activity log is in a hidden window pane at the bottom of the DocuShare File Monitor window. The activity log may be viewed by dragging the frame of the hidden window pane upwards. You can locate the upper frame of the hidden window pane by moving your cursor over the lower part of the main window. The frame will be indicated when the cursor changes into the frame drag cursor (i.e., two horizontal lines with arrows pointing vertically).

    Monitor Menu

    • Exit - Terminates the DocuShare File Monitor application.

    Edit Menu

    • Copy - Copies text from the activity log.

    • Clear All - Clears the activity log.

    View Menu

    • List - Shows the file titles and icons only.

    • Details - Shows other information.

    • Settings... - Starts the DocuShare Client Settings dialog.

    • Events - Enables/disables activity logging (grayed when the focus is on the WIP list).

    • Refresh - Forces rescanning of the WIP folder and updating of the WIP list.

    • Status bar - Shows/hides the status bar at the bottom of the main window.

    Document Menu
  • Lock - Locks the DocuShare file on the server associated with a selected file in the work-in-progress folder. A file checked out from Explorer is automatically locked. However, a file opened through the ODMA Interface or the Windows Open/Save As dialog may not be checked out (unless you checked the Lock option). In such a case, you may use this menu item to create the lock manually.

  • Unlock - Unlocks the source file.

  • Save Local - Lets you save a selected file to a local folder in your machine from the work-in-progress folder.

  • Check In - Allows you to check in a selected file. If the file is not assigned with a file handle, the file may only be uploaded as a new document.

  • Stop - Cancels an ongoing upload process.

  • Delete - Deletes the local copy from the work-in-progress folder. If the source file is locked, deleting will remove the lock.

  • Help
  • Contents - Allows you to view the file.

  • About DocuShare Client... - Enables you to view the version information for the DocuShare Client.

  • Buttons
  • Check In - Allows you to check in a selected file. If the file is not assigned with a file handle, the file may only be uploaded as a new document.

  • Stop - Cancels an ongoing upload process.

  • Save Local - Lets you save a selected file to a local folder in your machine from the work-in-progress folder.

  • Delete - Deletes the local copy from the work-in-progress folder. If the source file is locked, deleting will remove the lock.

  • List - Shows the file titles and icons only.

  • Details - Shows other information.

  • Remarks
    The DocuShare File Monitor lists all files that are currently held in the work-in-progress folder. You can use the monitor window to find or review what files have been checked out and what states those files are in. For example, you may see that a file was last checked in at 4:00 p.m. and is still being edited using Microsoft Word. You do not need to start the DocuShare File Monitor manually - it will be started automatically when you check out a document the first time. The DocuShare File Monitor window is usually hidden from view. To view the work-in-progress list, double-click on the DocuShare File Monitor icon on the taskbar.

    When you check out a DocuShare file via the Windows Explorer, a copy of the file is downloaded to a work-in-progress directory and is indexed by the DocuShare File Monitor for editor tracking and check-in purposes. After it locks the file, the DocuShare File Monitor starts an editor program associated with the document type of the file. When you close the edited file or exit the editor program, the DocuShare File Monitor prompts you to save the file back to DocuShare. You may fill in optional fields and click on Check In to start the upload process. At this point, you may decide to save the file as a new document in DocuShare instead of saving it back as a new version of the checked out file. If you do, select Save As, and you will be prompted with a new document check-in form.

    If you do not want to save the file (despite the edit changes you made), select Cancel. The DocuShare File Monitor invalidates the file handle assigned to the canceled local file. The DocuShare File Monitor then asks you if it is OK to delete the local copy that you were working on. If you want to keep the file, select No. If the WIP folder is not open, it will then open. Highlight the file in the list, and select Save Local from the Document menu (or from the tool bar). You may also select Check In to save the file as a new DocuShare document. Remember that, once you cancel, the original file handle is lost. You cannot save it back as a new version of the checked out file. If you still need to save it as a new version, follow these steps: Save the file to a local directory using Save Local, start Explorer, go to the file to replace, select New>Version from the context menu, and open the local file you saved.

    Another note regarding check in cancellation: The DocuShare File Monitor leaves the file locked when you cancel. Should you decide to save it to a local folder, be sure to either unlock the file or delete it using the respective menu items of the DocuShare File Monitor. The DocuShare File Monitor will notify Explorer of a lock status change for display updating. Although a canceled file may be unlocked from Explorer, you will continue to see a padlock in the WIP folder because the DocuShare File Monitor is not notified. When you delete the file, the DocuShare File Monitor displays an error message indicating that the unlock failed.

    You do not need to close a checked-out file (or exit the editor program) to initiate a check-in. If you want to save an interim version, you can do so by first selecting Save in the editor and then by selecting Check In from the DocuShare File Monitor. Note however, that depending on how the editor manages an open file, the file may be marked non-shareable, and the Check In command may fail.

    To close the DocuShare File Monitor window, either click on the (X) close box at the upper- right hand corner or select Close from the system command menu (right-click on the DocuShare File Monitor title bar to get this menu). Under normal circumstances, you should not select Exit from the Monitor menu. The DocuShare File Monitor application exits automatically when the Windows session is shut down, restarted, or a new user logs in.


    Open/Save/Save As... Dialogs


    Desktop applications that support the Window's Common Dialog will have access to DocuShare through their Open and Save/Save As… dialogs. The DocuShare folder can be selected and the DocuShare collection hierarchy can be traversed. An informational side box is presented to help navigate through DocuShare. The Mode: field notes whether the action will result in a check-in, check-out (lock and open), or browse.

    About Controls
    Top area - Displays Help text regarding what to do, depending on the currently selected item.

    Mode - Indicates file access mode and data direction depending on the currently selected item. Possible modes are:

  • Select server - open the selected server folder.

  • Open collection - open the selected collection.

  • Browse - open the selected file without locking it.

  • Check out - open the selected file and lock it.

  • Check in document - check in a file as a new document in DocuShare.

  • Check in version - check in a file as the latest version of a DocuShare document.

  • Files you selected (bottom area) - Shows the name(s) of the selected item(s).

    Lock (check box) - Check to lock the selected file. Available in the Open mode. Grayed in the Save mode. Note that this option is pre-selected by the "Lock Common Dialog opened files" option in the DocuShare Windows Client Properties dialog.

    File name - User specifies the title of a document to open or save. The file name field is grayed when in the Open mode. A file must be selected from the directory list. The name field becomes editable in the Save mode. When viewing a DocuShare collection, the field is grayed regardless of the mode.

    Files of type - User specifies a file type. The types are made available by the editor program.

    To Check Out an Existing File for Editing From DocuShare and then save it back:

    1. Select Open from the File menu of the editor application.

    2. Navigate to the DocuShare folder.

    3. Go to the DocuShare collection that holds the file. If you have not logged onto the server, you will be prompted to enter a password.

    4. Check the Lock option located in the DocuShare Informational box. If you do not want to lock the document, leave it unchecked.

    5. Select the file. The Mode: line should read "Check Out Single" (or "Check Out Multiple" for multiple file selection). In addition, the "Files you selected" area should mention the file you just selected.

    6. To load the file into the editor, click on "OK" or double-click on the file name.

    7. The DocuShare Client downloads a copy of the file from the server (locking it if you enabled the Lock option), and places it in a work-in-progress folder. To view the document's work-in-progress status, double-click on the DocuShare File Monitor icon in the system tray. The WIP folder opens to show files that have been checked out and/or are currently being edited.

    8. Make your changes. While editing, you may select Save from the File menu. Note that Save writes out the changes you have made to the local copy of the file in the work-in-progress folder. It does not cause an actual check-in with the server.

    9. To save the file back to DocuShare, select Close from the File menu.

    10. DocuShare Client produces a form for checking in a new document version. This may take a few moments

    11. Fill in optional revision comments in the Version Comment field.

    12. Click on Check In.

    13. The DocuShare Client uploads the modified copy of the file with your comments and unlocks the file.

    14. Once the document is saved back, the DocuShare Client deletes the local copy from its work-in-progress folder.

    15. If you view the document history in Explorer, your latest version appears in the list. Note that two new versions appear if you have made two check-ins, one from the first Save and the other from closing the document window.

      Note that while browsing DocuShare collections, the file name field of the Open dialog is grayed. You are not allowed to type an arbitrary file name. You must select a name from the shown list.


    To Save a Local File to DocuShare:

    1. Load the document into the editor. Make your changes.

    2. Select Save As from the editor's File menu.

    3. In the Save As dialog, navigate to a destination DocuShare collection.

    4. The Mode description should read "Check In Document."

    5. Type in a file name. If you have selected a name from the list shown previously, de-select it by clicking somewhere in the blank area. The "Files you selected" area should be blank.

    6. Click OK.

    7. Your editor program saves the file to a work-in-progress folder of the DocuShare Client. The document appears in the Work-In-Progress Files list of the DocuShare File Monitor window.

    8. The DocuShare Client produces a form for checking in a new document. This may take a few moments.

    9. Fill in the summary and other optional fields.

    10. Click Check In.

    11. The DocuShare Client uploads the new document to the server.

    12. You may continue editing. If you do, however, you should lock the document from the DocuShare File Monitor window. The Save As mode does not lock the checked-in document automatically.

    13. Close the document. If the document has been modified since the first check-in, the DocuShare Client again prompts you with a check-in form.

    14. Once the document is saved, the DocuShare Client deletes the local copy from its work-in-progress folder.

    If an error occurs while uploading the file, or if you cancel the upload in progress, DocuShare Client prompts you to open the DocuShare File Monitor window (if not already open), review the status, and take action if necessary to resolve the problem. From the DocuShare File Monitor window, you may attempt to check in again, or save to a local folder on your machine. If you have already closed the editor application, you should also delete the finished file from the work-in-progress list. Note that when you exit from Windows, all leftover work-in-progress files are deleted automatically.

    To Overwrite an Existing DocuShare Document with a New Version:

    Follow the steps for saving a local file to DocuShare. Instead of typing a new name in the Save As dialog, however, select an existing name from the list. The Mode line should read "Check In Version." In addition, the "Files you selected" area should display the name you selected.

    Limitations
    You may not save a file in the DocuShare Client root folder or in any server folder. An error will result.

    After you check out a document, you may want to save it as a different DocuShare document. You can do this by following the above procedure for saving a local document. However, because of the way that the DocuShare Client tracks the document's location, the original document continues to be shown in the DocuShare File Monitor window after it is saved as a new document. If you have edited and saved the original document again after the initial check-in, when you close the second document (the new one that you created with the Save As dialog), you may be prompted for checking in not only the second document, but the original document as well. Should this happen, you can either continue with the check in, or let the DocuShare Client discard the original.

    When you use the Open or Save As menu the second time, the dialog box may show the current contents of a previously accessed work-in-progress folder of DocuShare Client (e.g., Temp_Folder_C-123). While nothing prevents you from doing so, you should not open a file from or save a new one to that folder. The folder is temporary and is used by the DocuShare Client for storing work-in-progress files that are mapped to a certain DocuShare collection. If you do save a file (by mistake) into this temporary directory, DocuShare Client asks you if you want to check it in. If you say yes, your file will be uploaded. However, doing so causes the DocuShare Client to not receive notification regarding the editor window's identity. This leads to a condition where a directly saved file is never removed from the Work-In-Progress Files list even after the editor window is closed. You need to manually remove it. To do this, open the File Monitor window and execute Delete from the Document menu.

    Non-standard functions are not supported. Some editor applications add custom buttons and/or other controls to the Windows Open/Save As dialog box. The DocuShare Client does not support them. Use of such a function may lead to an error.

    Some of the buttons in the dialog box are grayed when browsing a DocuShare server. Specifically, the Create New Folder button and the two List and Details buttons are grayed. To use these functions, right-click to pop up the context menu, and select the respective items.

    Some context menu items that are available in Explorer are not available in the Open/Save As dialog. They include Add Document, Lock, and Unlock.

    You can find the complete list of tested applications that work with the DocuShare Client through the application's Open/Save As dialogs in the README documentation. An application not listed may not work correctly.
    Table of Contents     Searching in DocuShare     DocuShare ODMA Client



    Copyright © 1997-2000 Xerox Corporation. All Rights Reserved. All Xerox product names mentioned in this document are trademarks of Xerox Corporation. All other product names mentioned in this document are trademarks of their respective companies.

    P/N 613P08550 3/00